Zur Startseite

Falcon - Cerințe

Falcon 5.x cerințe

Următoarele caracteristici reprezintă cerințele hardware și software minime pentru a lucra cu Falcon:

Sisteme de operare Hardware (cerințe minime) Interfață rețea KNX

Microsoft Windows XP SP3 (x32)

Microsoft Windows 7 SP1 (x32/x64)

Microsoft Windows 8/ 8.1 (x32/x64)

Microsoft Windows 10 x32/x64

Microsoft Server 2008 R2 SP1 (x64/x64)

Microsoft Server 2012 x64

 

 

CPU: ≥  1.5 GHz
RAM: ≥  2 GB
HDD: ≥  1 GB

 

 

  • USB
  • IP

Mediu de dezvoltare

Este necesară instalarea .NET Framework 4.0 (sau ulterioară). Aceasta poate fi integrată în configurarea mediului de dezvoltare. Consultaţi secţiunea Mediu de dezvoltare pentru a vedea dacă această etapă poate fi omisă.

Mediu de dezvoltare

Este necesar un mediu de dezvoltare care permite dezvoltarea DLL-urilor .NET Framework 4.0 (sau ulterior). Câteva exemple de medii de dezvoltare: Microsoft Visual Studio.

  1. Microsoft Visual Studio 2010 (sau ulterior): Nu sunt necesare alte cerinţe suplimentare privind mediul de dezvoltare. Informaţii suplimentare privind versiunile Microsoft Visual Studio şi cerinţele preliminare ale acestora pot fi găsite aici .
  2. Microsoft Visual Studio 2010 (sau ulterior) Express Edition: Nu sunt necesare alte cerinţe suplimentare privind mediul de dezvoltare. Informaţii suplimentare privind versiunile Microsoft Visual Studio şi cerinţele preliminare ale acestora pot fi găsite aici .

Nu se anticipează o versiune Falcon cu sistemele de operare susmenţionate într-un mediu virtual (precum Virtual PC®; VM Ware®). Lucrul pe aceste sisteme se execută pe riscul propriu al utilizatorului. În aceste cazuri, Asociaţia KNX nu va oferi garanţie şi asistenţă.

Cerinţe Falcon 2.x

Următoarele caracteristici reprezintă cerinţele hardware şi software minimale necesare pentru lucrul cu Falcon:

Sisteme de operare Hardware (cerințe minime) Interfață rețea KNX

Windows Vista; SP2 (x32/x64)

Windows 7 (x32/x64)

Windows Server 2003;
SP2 (x32/x64)

Windows Server 2008;
SP2 (x32/x64)

Windows Server 2008 R2;
SP1 (x32/x64)

CPU: ≥  1.5 GHz
RAM: ≥  1 GB
HDD: ≥  1 GB

  • RS232 (not on x64; not on server OS)
  • USB
  • IP

Mediu de dezvoltare

Compatibil COM (ex. VC++, VBasic, JavaScript, VBScript, php, …)

Nu se prevede lansarea unei versiuni Falcon cu sistemele de operare sus-menționate într-un mediu virtual (precum Virtual PC®; VM Ware®). Pe aceste sisteme, lucrați pe propriul risc. KNX Association nu oferă garanție și suport tehnic în acest caz.