Zur Startseite

Falcon - Requisitos

Requisitos da Falcon 5.x

As seguintes características abaixo são os requisitos mínimos de hardware e software para se trabalhar com a Falcon 5.x:

Sistemas Operativos Hardware (requisitos mínimos) Interface da Rede KNX

Microsoft Windows XP SP3 (x32)

Microsoft Windows 7 SP1 (x32/x64)

Microsoft Windows 8/ 8.1 (x32/x64)

Microsoft Server 2008 R2 SP1 (x64/x64)

Microsoft Server 2012 x64

CPU: ≥  1.5 GHz
RAM: ≥  2 GB
HDD: ≥  1 GB 

  • USB
  • IP

Ambiente de Desenvolvimento
Tem de se instalar o .NET Framework 4.0 (ou superior), podendo vir juntamente com a configuração do ambiente de desenvolvimento. Ver na secção de Ambiente de Desenvolvimento se se pode omitir esta etapa.

Ambiente de Desenvolvimento

É necessário um ambiente de desenvolvimento que suporte o desenvolvimento de DLLs do .NET Framework 4.0 (ou superior). Exemplos de ambientes de desenvolvimento são: Microsoft Visual Studio .

  1. Microsoft Visual Studio 2010 (ou superior): Não são necessários quaisquer outros pré-requisitos. Para mais informações sobre as versões do Microsoft Visual Studio e os seus pré-requisitos, clique aqui .
  2. Express Edition do Microsoft Visual Studio 2010 (ou superior): Não são necessários quaisquer outros pré-requisitos para o ambiente de desenvolvimento. Para mais informações sobre as versões do Microsoft Visual Studio e os seus pré-requisitos, clique aqui .

Não está prevista a instalação da Falcon para funcionar nos sistemas operativos acima referidos num ambiente virtual  (como Virtual PC®; VM Ware®). O funcionamento em tais ambientes ocorre por conta e risco de cada um. Neste caso, a Associação KNX não presta qualquer garantia ou assistência.

Requisitos da Falcon 2.x

As seguintes características são os requisitos mínimos para o hardware e software para se poder trabalhar com a Falcon:

Sistemas operativos Hardware (requisitos mínimos) Interface da Rede KNX

Windows Vista; SP2 (x32/x64)

Windows 7 (x32/x64)

Windows Server 2003;
SP2 (x32/x64)

Windows Server 2008;
SP2 (x32/x64)

Windows Server 2008 R2;
SP1 (x32/x64)

CPU: ≥  1.5 GHz
RAM: ≥  1 GB
HDD: ≥  1 GB

  • RS232 (não no x64; não no SO do servidor)
  • USB
  • IP

Ambiente de Desenvolvimento
Compatível com COM (tais como VC++, VBasic, JavaScript, VBScript, php,...)

Não está prevista a instalação da Falcon executada nos sistemas operativos acima mencionados em ambiente virtual  (como Virtual PC®; VM Ware®). O funcionamento em tais ambientes ocorre por conta e risco de cada um. Neste caso, a garantia e a assistência não são disponibilizadas pela Associação KNX.