Zur Startseite

Falcon - Prérequis

Falcon 5.x - Prérequis

Les caractéristiques suivantes sont les prérequis matériels et logiciels pour l’installation et l’utilisation de Falcon 5.x:

Systèmes d‘exploitation Matériel (Prérequis minimum) Interface réseau KNX

Microsoft Windows XP SP3 (x32)

Microsoft Windows 7 SP1 (x32/x64)

Microsoft Windows 8/ 8.1 (x32/x64)

Microsoft Windows 10 x32/x64


Microsoft Server 2008 R2 SP1 (x64/x64)

Microsoft Server 2012 x64

 

 

CPU: ≥  1.5 GHz
RAM: ≥  2 GB
HDD: ≥  1 GB

 

 

  • USB
  • IP

Environnement de développement

Le Framework .NET 4.0 (ou ultérieur) doit être installé. Cela pourrait être installé avec la configuration de l'environnement de développement. Vérifiez si cette étape peut être sautée dans le chapitre concernant l'environnement de développement.

Environnement de développement

Un environnement de développement qui supporte le développement de DLLs du Framework .NET 4.0 (ou ultérieur) est nécessaire. Exemples d'environnements de développement : Microsoft Visual Studio.

  • Microsoft Visual Studio 2010 (ou ultérieur) : Aucun autre prérequis sur l'environnement de développement n’est nécessaire. De plus amples d'informations sur les versions de Microsoft Visual Studio et sur ses prérequis peuvent être trouvées ici .
  • Microsoft Visual Studio 2010 (ou ultérieur) Express Edition : Aucun autre prérequis sur l'environnement de développement n’est nécessaire. De plus amples d'informations sur les versions de Microsoft Visual Studio et sur ses prérequis peuvent être trouvées ici .

Une version de Falcon compatible avec les systèmes d'exploitation mentionnés ci-dessus dans un environnement virtuel (comme Virtual PC®; VM Ware®) n’est pas prévue. Sur ces systèmes, vous travaillez est à vos propres risques. Aucune garantie ou support ne sera fournie par KNX Association dans ce cas.

Falcon 2.x - Prérequis

Les caractéristiques suivantes sont les prérequis matériels et logiciels pour l’installation et l’utilisation de Falcon 2.x:

Systèmes d‘exploitation Matériel (Prérequis minimum) Interface réseau KNX

Windows Vista; SP2 (32/64 Bit)

Windows 7 (32/64 Bit)

Windows Server 2003;
SP2 (32/64 Bit)
Windows Server 2008;
SP2 (32/64 Bit)
Windows Server 2008 R2;
SP1 (32/64 Bit)

CPU: ≥  1.5 GHz
RAM: ≥  1 GB
HDD: ≥  1 GB

 

 

  • RS232 (pas sur x64; Pas sur OS Serveur)
  • USB
  • IP

Environnement de développement
COM-compatible (comme VC++, VBasic, JavaScript, VBScript, php,...)

Une version de Falcon avec les systèmes d’exploitation ci-dessus dans un environnement virtuel (comme Virtual PC PC®; VM Ware®) et ou un Bureau Distant n’est pas prévu. Sur ces systèmes, vous travaillez à vos propres risques. Aucune garantie ou support ne sera fourni par KNX Association dans ce cas.